Владельцам старых iPhone и iPad необходимо обновиться до iOS 10.3.4

Пользователям, которые всё ещё продолжают активно пользоваться iPhone 5 и iPad четвёртого поколения (с поддержкой Wi-Fi и сотовой сетей), рекомендуется срочно обновить операционную систему до версии iOS 10.3.4 – до 3 ноября. Иначе они рискуют столкнуться с проблемами в работе GPS, веб-серфинга и электронной почты. Об этом говорится на странице поддержки Apple.

Необходимость установки iOS 10.3.4 связана с обнаруженной в старых версиях системы проблемы с работой геолокации (GPS), за счет чего многие приложения, синхронизирующие время по навигационной системе, не могут нормально функционировать. Проблема заключается в том, что в самой iOS время тоже автоматически настраивается через GPS, но из-за того, что в системе подсчетов времени существует некое ограничение, о котором Apple подробно не распространяется, после 3 ноября 2019 г. смартфон начнет устанавливать некорректное время. В итоге эта ошибка в системе приведет к отключению GPS в смартфоне, в связи с чем перестанет работать браузер Safari, нуждающийся в синхронизации времени.

Отключение GPS повлечет за собой не только неработоспособность Safari, но и невозможность подключения к iCloud Backup, что и станет причиной неработающего обновления «по воздуху». Из строя также выйдут клиент электронной почты, магазин приложений App Store и все навигаторы, умеющие определять местоположения пользователя только по GPS-координатам.

Большинство современных устройств имеют встроенное решение для нормальной работы при таких случаях, поэтому пользователям не нужно ни о чем беспокоиться. Но некоторые устройства, такие как iPhone 5, нуждаются в обновлении программного обеспечения, чтобы как раз добавить необходимые механизмы борьбы с проблемой подсчёта дат GPS.

Apple разослала предупреждения только владельцам iPhone 5, но под ударом также могут оказаться пользователи и других устаревших гаджетов компании. В их число входят iPhone 4S, iPad второго, третьего и четвертого поколений и компактный iPad mini первого поколения. Для этих устройств Apple выпустила iOS версии 9.3.6. Дополнительно Apple отметила, что проблема с GPS не касается плееров iPod touch или старых планшетов iPad, которые поддерживают только Wi-Fi и не содержат модема сотовой связи.

Тем, кто не успеет обновиться до указанной даты, придётся делать это через компьютер, так как функция обновлений по воздуху и резервного копирования через iCloud без интернет-соединения станет недоступна. Сделать это можно в меню «Обновление ПО» в настройках.

Источник: Apple

Обсуждение

Оставить сообщение
Обсуждение на форуме целиком